The problem has been resolved, and the historical data is now correct. The team is now monitoring the situation.
Posted Aug 06, 2025 - 09:32 UTC
Identified
The main cause has been found. The team is beginning to address the inaccuracy and correct the historical data.
Posted Aug 05, 2025 - 08:08 UTC
Investigating
The data in the MRR and New Subscription charts is inaccurate once again. This is the same issue for which we closed an incident on July 15, 2025. We are investigating the problem. Core services remain unaffected.