Issue with API
Incident Report for Qonversion
Resolved
The incident has been resolved. Attribution data (ASA and others) is still paused; we’re working on restoring it. You’ll start seeing data affected by the incident in your dashboard within the next 24 hours.

On top of that, our team is entirely focused on making several urgent changes that will be implemented during this week:
- Add extra caching mechanism for our APIs, enabling them to work in case databases are fully down
- Add additional replicas to the base cluster
- Collaborate with the cloud provider to prevent the reoccurrence of the issue
Posted Jan 18, 2023 - 11:45 UTC
Update
The incident has been resolved. We are monitoring the situation. Attribution data (ASA and others) is still paused; we’re working on restoring it. You’ll start seeing data affected by the incident in your dashboard within the next 24 hours.

On top of that, our team is entirely focused on making several urgent changes that will be implemented during this week:
- Add extra caching mechanism for our APIs, enabling them to work in case databases are fully down
- Add additional replicas to the base cluster
- Collaborate with the cloud provider to prevent the reoccurrence of the issue
Posted Jan 18, 2023 - 08:41 UTC
Update
Resolved
- Analytics & Subscription Management modes are fully operational
- Subscription Events are being sent to enabled integrations

In progress:
- Charts’ data & older revenue events actualisation are in progress
- Attribution (ASA and other) is paused at the moment; we’re working on restoring it
- We’re adding an additional caching layer between our cloud provider and us to avoid potential service interruptions
Posted Jan 17, 2023 - 22:13 UTC
Update
Integrations are up and running.

The next steps:
- To resend events affected by the incident
- To have other Qonversion’s system parts work as expected.

We’ll keep you updated.
Posted Jan 17, 2023 - 16:35 UTC
Update
Qonversion API is operational, and purchases are working as expected. We’re monitoring the situation and working on problems with other parts of the service (integrations, raw data reports, etc.). Data in dashboards is still delayed. We’re working on this at the moment. We’ll be providing more updates soon.
Posted Jan 17, 2023 - 14:25 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 17, 2023 - 12:42 UTC
Update
We keep monitoring the situation. The Subscription management mode & API have been restored. Data in dashboards is delayed and actual for the time before the incident starts.

We have yet to deal with the aftermath of the incident. We will get back to you with details as soon as the technical work is completed.
Posted Jan 17, 2023 - 12:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 17, 2023 - 12:09 UTC
Update
Our team is continuing to work on getting the service back up and running on the new cluster. We’re closely working with our cloud provider. Our team is integrating the recently released patch for the MySQL software to resolve the incident.
Posted Jan 17, 2023 - 09:58 UTC
Update
Our team is currently trying to get the service back up and running on the new cluster. We’re closely working with our cloud provider, which is also trying to run our service back up on the old cluster with our backup data. We’re planning to complete the final steps for migration to a new database and assuming to fix this issue as soon as possible.
Posted Jan 17, 2023 - 05:20 UTC
Update
We are still working on resolving this problem and will give you more information soon.
Posted Jan 16, 2023 - 19:15 UTC
Update
Unfortunately, the patch was not successful. Our engineers are now exploring next steps.
Posted Jan 16, 2023 - 16:08 UTC
Update
Our team is currently in the process of integrating the recently released patch for the MySQL software. This patch includes various updates and fixes that will improve the overall performance and security.
Posted Jan 16, 2023 - 14:42 UTC
Identified
The issue has been identified. We have escalated that to our database provider. We are working on the fix.
Posted Jan 16, 2023 - 14:05 UTC
Investigating
We're experiencing an elevated level of API errors and are currently looking into the issue.
Posted Jan 16, 2023 - 13:23 UTC
This incident affected: API (API).